BMW 1-Series Forum (F20) 135i - 1Addicts.com > Second Generation 1 Series Forum > 2012 BMW 1-Series Sporthatch (F20) Discussion > Misfiring after a stage 1 remap - Bmw m135i
Post Reply
 
Thread Tools Search this Thread
      08-18-2022, 05:30 PM   #1
Tm135i
New Member
0
Rep
5
Posts

Drives: Bmw m135i
Join Date: Aug 2022
Location: Uk

iTrader: (0)

Misfiring after a stage 1 remap - Bmw m135i

Hi all,

I recently had my m135i (n55) remapped. For the first few weeks everything was fine and running great. I upgraded my charge pipe shortly after the remap as I was told they are prone to cracking. Everything still seemed fine with car, no issues. However over the last 2-3 weeks I noticed the car was slightly misfiring when idle, but was having no issue when actually driving the car. Iíve searched many forums and people suggested to change the spark plugs, so I changed them to NGK 97506s and the misfiring is still occurring when idle. I did not gap the new plugs but was wondering if it would be worth doing to see if it fixes the misfiring before starting to change more parts and spending more money.

Any help would be appreciated, thank you.
Appreciate 0
      08-19-2022, 02:25 AM   #2
IJO
Private
7
Rep
72
Posts

Drives: BMW 116I F20
Join Date: Apr 2022
Location: UK

iTrader: (0)

My 116i started to misfire slightly (idle roughly) and hesitates when the gas pedal is moved, after a MHD remap, but only for a few seconds after a cold start.

I changed the plugs for colder NGKs, fitted Ignition Projects multi spark coils which helped.

I just live with it although I have yet to see if it is better or worse in cold weather.

(I probably should reverse the remap and see if the idle is still rough to prove it is this)

I think the delay before the symptoms started is probably due to the ecu adaptation. Remapping resets them.
Appreciate 0
      08-19-2022, 08:51 AM   #3
Tm135i
New Member
0
Rep
5
Posts

Drives: Bmw m135i
Join Date: Aug 2022
Location: Uk

iTrader: (0)

Thanks for your reply,

I think Iím going to try changing the coils and see if that helps, if not then I might take the map off the car and go from there.
Appreciate 0
      08-19-2022, 09:01 AM   #4
IJO
Private
7
Rep
72
Posts

Drives: BMW 116I F20
Join Date: Apr 2022
Location: UK

iTrader: (0)

Quote:
Originally Posted by Tm135i View Post
Thanks for your reply,

I think Iím going to try changing the coils and see if that helps, if not then I might take the map off the car and go from there.
i don't think its the coils. These tend to fail under high load rather than at idle and you'd get misfire fault codes.

Check the coil connectors are pushed in firmly.

I never had any DTCs. I have come to the conclusion that the new map is slightly underfuelling at idle because it also hesitates / jerks very slightly when setting off from rest even when at operating temperature unless I use more revs.

Mine will run okay with the maf sensor unplugged and this does cure the issues but I've never driven it for more than a couple of miles with it unplugged. (I did change the maf and precat O2 sensor when I bought the car as the tailpipe looked like an old diesel's and mpg was poor.)
Appreciate 0
      08-19-2022, 11:19 AM   #5
Tm135i
New Member
0
Rep
5
Posts

Drives: Bmw m135i
Join Date: Aug 2022
Location: Uk

iTrader: (0)

Would you recommend I just remove the map?
Appreciate 0
      08-19-2022, 11:22 AM   #6
IJO
Private
7
Rep
72
Posts

Drives: BMW 116I F20
Join Date: Apr 2022
Location: UK

iTrader: (0)

Quote:
Originally Posted by Tm135i View Post
Would you recommend I just remove the map?
If you used the MHD app its easy to quick and reflash the DME with the stock file and see if this makes a difference.

I haven't bothered as i only get the rough idle after a cold start.
Appreciate 0
      08-19-2022, 12:34 PM   #7
Tm135i
New Member
0
Rep
5
Posts

Drives: Bmw m135i
Join Date: Aug 2022
Location: Uk

iTrader: (0)

I had it done at a local tuners. Im just not sure what to do as I donít want to keep spending on things that arenít going to help. I think Iíll call the tuner in the morning and see what options I have.

Mine is misfiring everytime Iím idle.
Appreciate 0
      08-19-2022, 12:38 PM   #8
IJO
Private
7
Rep
72
Posts

Drives: BMW 116I F20
Join Date: Apr 2022
Location: UK

iTrader: (0)

Quote:
Originally Posted by Tm135i View Post
I had it done at a local tuners. Im just not sure what to do as I donít want to keep spending on things that arenít going to help. I think Iíll call the tuner in the morning and see what options I have.

Mine is misfiring everytime Iím idle.
In that case the tuner needs to get the map modified.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:25 AM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST