BMW 1-Series Forum (F20) 135i - 1Addicts.com > BIMMERPOST Universal Forums > General BMW News and Cars Discussion > Glow plugs broke
Post Reply
 
Thread Tools Search this Thread
      08-07-2022, 05:32 PM   #1
Al3dHell
New Member
0
Rep
7
Posts

Drives: BMW 320d e90 163 hp
Join Date: Apr 2020
Location: Romania

iTrader: (0)

Glow plugs broke

Hello guys! The car is a E90 M47 '06 automatic.

Three years ago i went with the car on a ride and i've stopped somewhere for 30minutes.
When i came back i wanted to go back home. I've put the car on R and drive back 3 meteers and the car died.
It was my first time experiencing this. When i arrived home i've used ISTA to check the errors.
The car got 5 errors : glow plug module & glow plug 1-4
I've replaced them with new ones from BERU ( the glow plug module and glow plugs ).
The car was fine without errors for an year. The the errors came back. I drove 15k kilometers in that year.
I've watched videos to repair the 2 relays and i did it. I've checked them with a multimeteer and they were good.
The 2 repaired lasted me only 1 month. I saw that a lot of people didnt had problems with them repaired.
I didn't want any more troubles and i got a new one again. But unfortunately it lasted only a few weeks.
And since then i drove the car with it broke. I had no issues with the car.
But lately, the car died again.. And a lot of times almost dies when i start it and i rotate the wheel.
The car has only that 5 errors. I don't know if the glow plugs is affecting my car with something.
What am I supposed to do now? Replace it again and it would last me again 1 month?? I'm not willing to pay 160euros monthly only on the glow plug module.

Any help will be welcomed!
Appreciate 0
      08-08-2022, 12:01 AM   #2
Theodore
First Lieutenant
Theodore's Avatar
United_States
571
Rep
392
Posts

Drives: 2011.5 E92 M3
Join Date: Oct 2015
Location: Tampa Bay, FL

iTrader: (5)

Check out this thread here.
__________________
What I Wish I Knew When I First Bought My E9X M3 Can Be Found Here
E9X M3 Exact Original Equipment (OE) Equivalent Parts Can Be Found Here
E9X M3 Common Torque Specs Can Be Found Here
E9X M3 "Factory" Tools Can Be Found Here
Appreciate 0
      08-08-2022, 05:05 PM   #3
zener
BMW enthusiast since 2004
47
Rep
60
Posts

Drives: E65 730d, F10 520d
Join Date: May 2022
Location: Finland

iTrader: (0)

Check if the power cable for the glow plug module has melted and replace it. Had this issue with my E65...
Appreciate 0
      08-09-2022, 03:39 PM   #4
Jetta85
New Member
2
Rep
14
Posts

Drives: F10 530d
Join Date: Jul 2022
Location: Germany

iTrader: (0)

I’ve had something similiar but not monthly, my BMW 530d needs nearly every year a new glow plug module. But still when it is broken the car drives normal
Also in the winter time. Only more vibrations are recognised. Also in ISTA is written that the glow plugs are still get power although the module is broken, like ermergency function. Died you also checked the cables of the injectors ?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:33 PM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST