BMW 1-Series Forum (F20) 135i - 1Addicts.com > Second Generation 1 Series Forum > DIY Guides and Instructions > [Help] PDC control button with rear PDC only
Post Reply
 
Thread Tools Search this Thread
      02-04-2019, 11:18 AM   #1
goands
New Member
goands's Avatar
Belgium
4
Rep
8
Posts

Drives: BMW M2 F87 2017 - Mineral Grey
Join Date: Oct 2017
Location: Ertvelde, Belgium

iTrader: (0)

Question [Help] PDC control button with rear PDC only

Hi guys,

I recently tried to help a friend out by replacing his drivemode selector panel without a PDC control button to the one with a PDC control button.

He was encountering an irritating problem when he's put the car in R and brings it back in neutral, the PDC keeps beeping.

!!! On my M2, I was experiencing the same problem and simply changed the panel like I did in his car. It was plug & play and worked like a charm. !!!

--

But in his '13 F20 116d, the extra button doesn't seem to do anything.
When bringing the car in R, the LED pops on. But there is no way to control the PDC with the button like I was able to do in my car.

Does anyone tried this as well on the F20? Maybe there's some coding required, I'm able to code with ESYS so in that case, it would be nice to hear from you guys.

Thanks!

from this


to this
Appreciate 0
      02-04-2019, 10:31 PM   #2
No one
Captain
351
Rep
862
Posts

Drives: F21 118i
Join Date: Oct 2014
Location: Undisclosed

iTrader: (0)

This switch is for complete (front and rear) PDC. So coding should help: https://f30.bimmerpost.com/forums/sh...d.php?t=869735.
Appreciate 0
      02-06-2019, 08:50 AM   #3
dorgo
New Member
1
Rep
17
Posts

Drives: F20 116i
Join Date: Apr 2014
Location: Israel

iTrader: (0)

Exactly same issue here (F20 116i 2013).
The LED works, but nothing happens on click.

I read this post:
https://f87.bimmerpost.com/forums/sh...1345311&page=7
and understood this is a lot of work..

can you please update if coding solved this?
In addition, can you please add the model of the car?

Thanks!
Appreciate 0
      01-17-2020, 02:59 PM   #4
french.f20
New Member
0
Rep
7
Posts

Drives: BMW F20 (116D) - 2012
Join Date: Jan 2020
Location: France

iTrader: (0)

Same problem. I haven't seen your topic, so I did mine... But same issue with a F20 116d from 2012.
I'm sure that it's not complicated, but we have to know what to code.
Appreciate 0
      05-12-2020, 11:20 AM   #5
Shaky2000
Registered
United Kingdom
0
Rep
4
Posts

Drives: M135i LCI
Join Date: May 2020
Location: Surrey

iTrader: (0)

I am newbie - Have you managed to get this sorted.
I think you need to make sure PIN1 (on the switch) is connected to PIN 28 (on the control Module) - PIN2 is already connected if you have the green light on the button.
Appreciate 0
Post Reply

Bookmarks

Tags
coding, f20, parking sensors, pdc, retrofit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:55 AM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST