BMW 1-Series Forum (F20) 135i - 1Addicts.com > Second Generation 1 Series Forum > 2012 BMW 1-Series Sporthatch (F20) Discussion > Urgent Help!
Post Reply
 
Thread Tools Search this Thread
      09-14-2020, 04:00 AM   #1
328iking
Private First Class
15
Rep
193
Posts

Drives: 328i
Join Date: Apr 2019
Location: Ipswich, Suffolk

iTrader: (0)

I installed an mmi andream nbt CarPlay unit in a friends 1 series 2013 f20. All was good (no issues present which will be described later in post), wired up and tested it before putting it all back together. Put everything back together, tested it, and the wipers came on and stayed on. I thought that's weird as not touched the wiper stalk. The stalk does nothing to turn it off.

So I started the car, battery was almost dead and it barely started. The wipers still on, indicator stalk not working and the lights are in the off position but the main lights are on.

We disconnected battery for 10mins then 30mins to reset it, still the same. Left the car overnight to sleep and this morning, no change.

I am confused by it all as I only touched the headunit to install the mmi box.

Any urgent help would be appreciated.

Edit: pls note I also removed the mmi unit and the issue remains.
Appreciate 0
      09-14-2020, 06:18 AM   #2
Sidewinder1970
New Member
Sidewinder1970's Avatar
Netherlands
9
Rep
25
Posts

Drives: BMW f20 116i
Join Date: Dec 2017
Location: Netherlands

iTrader: (0)

Garage List
2012 BMW F20  [5.00]
1. ignition on, make sure you have all doors and boot closed. If one door is open, it will not work.

2. Press the odometer reset button and keep it pressed until the BC screen changes (at least 10'').

3. When the screen changes, release the button. It will display a menu with numbered options. To scroll to each option you have press once the ODO resete button.

4. Go to option No. 4 UNLOCK and then press the odo reset button for a few seconds. It will enter the menu of this option and it will ask you for the unlock code.

5. The unlock code is the sum of the last 5 digits of your VIN. For example if your VIN is E123456, then the unlock code will be the number 20.

6. Enter the unlock code by pressing the odo reset button so many times required (in our example 20 times), until the number of the unlock code is displayed on the screen. If you accidentaly press the button more times than the required, worry not, just keep pressing it until it starts from 0 again.

7. Once you enter the unlock code, press again the odo rest button for a few seconds, to go to the previous menu. Now, the full unlocked menu should be displayed.

8. Scroll through all the option. On of the option give you een software reset choice. To enter this option just press for a few seconds the odo reset button.

If this doesnít help BimmerLink is a option.

Good luck.
Appreciate 0
      09-14-2020, 08:36 AM   #3
328iking
Private First Class
15
Rep
193
Posts

Drives: 328i
Join Date: Apr 2019
Location: Ipswich, Suffolk

iTrader: (0)

Quote:
Originally Posted by Sidewinder1970 View Post
1. ignition on, make sure you have all doors and boot closed. If one door is open, it will not work.

2. Press the odometer reset button and keep it pressed until the BC screen changes (at least 10'').

3. When the screen changes, release the button. It will display a menu with numbered options. To scroll to each option you have press once the ODO resete button.

4. Go to option No. 4 UNLOCK and then press the odo reset button for a few seconds. It will enter the menu of this option and it will ask you for the unlock code.

5. The unlock code is the sum of the last 5 digits of your VIN. For example if your VIN is E123456, then the unlock code will be the number 20.

6. Enter the unlock code by pressing the odo reset button so many times required (in our example 20 times), until the number of the unlock code is displayed on the screen. If you accidentaly press the button more times than the required, worry not, just keep pressing it until it starts from 0 again.

7. Once you enter the unlock code, press again the odo rest button for a few seconds, to go to the previous menu. Now, the full unlocked menu should be displayed.

8. Scroll through all the option. On of the option give you een software reset choice. To enter this option just press for a few seconds the odo reset button.

If this doesn’t help BimmerLink is a option.

Good luck.
I have BimmerLink but didn't see anything.

Have asked him to try your method.

He now says the below isn't working? Are they all controlled by the same module or is there any pattern.



Windscreen wipers always on / lights always on
Heating (hot) always on
Indicators / windscreen wiper stalks inop
Heating controls / Air con inop
Volume disc controls inop
Horn inop
Appreciate 0
      09-14-2020, 10:06 AM   #4
328iking
Private First Class
15
Rep
193
Posts

Drives: 328i
Join Date: Apr 2019
Location: Ipswich, Suffolk

iTrader: (0)

Quote:
Originally Posted by Sidewinder1970 View Post
1. ignition on, make sure you have all doors and boot closed. If one door is open, it will not work.

2. Press the odometer reset button and keep it pressed until the BC screen changes (at least 10'').

3. When the screen changes, release the button. It will display a menu with numbered options. To scroll to each option you have press once the ODO resete button.

4. Go to option No. 4 UNLOCK and then press the odo reset button for a few seconds. It will enter the menu of this option and it will ask you for the unlock code.

5. The unlock code is the sum of the last 5 digits of your VIN. For example if your VIN is E123456, then the unlock code will be the number 20.

6. Enter the unlock code by pressing the odo reset button so many times required (in our example 20 times), until the number of the unlock code is displayed on the screen. If you accidentaly press the button more times than the required, worry not, just keep pressing it until it starts from 0 again.

7. Once you enter the unlock code, press again the odo rest button for a few seconds, to go to the previous menu. Now, the full unlocked menu should be displayed.

8. Scroll through all the option. On of the option give you een software reset choice. To enter this option just press for a few seconds the odo reset button.

If this doesn’t help BimmerLink is a option.

Good luck.
This didn't work.
Appreciate 0
      09-14-2020, 03:43 PM   #5
Sidewinder1970
New Member
Sidewinder1970's Avatar
Netherlands
9
Rep
25
Posts

Drives: BMW f20 116i
Join Date: Dec 2017
Location: Netherlands

iTrader: (0)

Garage List
2012 BMW F20  [5.00]
Dang, then I am out of options. Someone with bmw ista system can help you?
Appreciate 0
      09-14-2020, 03:44 PM   #6
328iking
Private First Class
15
Rep
193
Posts

Drives: 328i
Join Date: Apr 2019
Location: Ipswich, Suffolk

iTrader: (0)

Quote:
Originally Posted by Sidewinder1970 View Post
Dang, then I am out of options. Someone with bmw ista system can help you?
Trying to install it now. His battery is at 80% so we think it's his battery. So going to replace it tomorrow
Appreciate 0
      09-16-2020, 10:04 AM   #7
DomMuc
Private
Germany
10
Rep
93
Posts

Drives: F20 M135i
Join Date: Nov 2012
Location: Munich

iTrader: (0)

looks like you did mess up with the wiring... wipers go on if dsc has no connection per Can-bus to steering colum.... so check your wiring....
Appreciate 0
      09-16-2020, 10:09 AM   #8
328iking
Private First Class
15
Rep
193
Posts

Drives: 328i
Join Date: Apr 2019
Location: Ipswich, Suffolk

iTrader: (0)

Quote:
Originally Posted by DomMuc View Post
looks like you did mess up with the wiring... wipers go on if dsc has no connection per Can-bus to steering colum.... so check your wiring....
Lol wiring. There isn't any. Unplug quad lock and put in another quad lock. And run cable from mmi box to screen. Nothing to do with the fem.

Also I returned back to stock and same issue applies.

His battery reads 10.5v and have a faulty fuse error code in the fem. these are next to check
Appreciate 0
      09-16-2020, 11:26 AM   #9
Sidewinder1970
New Member
Sidewinder1970's Avatar
Netherlands
9
Rep
25
Posts

Drives: BMW f20 116i
Join Date: Dec 2017
Location: Netherlands

iTrader: (0)

Garage List
2012 BMW F20  [5.00]
I canít find the link but Iíve read somewhere that you can solve some battery issues by registration the (old/same) battery again with bimmerlink. The issue in that link was also a low battery like 80%. After renewing the registration of the same battery and a overnight battery charge, the battery works at 95/98%.
Somehow the battery can reset via this method.

Last edited by Sidewinder1970; 09-16-2020 at 11:39 AM..
Appreciate 0
      09-16-2020, 03:48 PM   #10
328iking
Private First Class
15
Rep
193
Posts

Drives: 328i
Join Date: Apr 2019
Location: Ipswich, Suffolk

iTrader: (0)

Quote:
Originally Posted by Sidewinder1970 View Post
I can’t find the link but I’ve read somewhere that you can solve some battery issues by registration the (old/same) battery again with bimmerlink. The issue in that link was also a low battery like 80%. After renewing the registration of the same battery and a overnight battery charge, the battery works at 95/98%.
Somehow the battery can reset via this method.
I was thinking this but didn't want to screw anything up with the battery.
Appreciate 0
      09-16-2020, 04:01 PM   #11
Sidewinder1970
New Member
Sidewinder1970's Avatar
Netherlands
9
Rep
25
Posts

Drives: BMW f20 116i
Join Date: Dec 2017
Location: Netherlands

iTrader: (0)

Garage List
2012 BMW F20  [5.00]
Itís worth trying. Low battery power can screw up your ecu and other controle units. Good luck.
Appreciate 0
      09-21-2020, 04:01 PM   #12
328iking
Private First Class
15
Rep
193
Posts

Drives: 328i
Join Date: Apr 2019
Location: Ipswich, Suffolk

iTrader: (0)

Quote:
Originally Posted by Sidewinder1970 View Post
It’s worth trying. Low battery power can screw up your ecu and other controle units. Good luck.
It was a blown fuse on fem
Appreciate 0
      09-21-2020, 11:57 PM   #13
Sidewinder1970
New Member
Sidewinder1970's Avatar
Netherlands
9
Rep
25
Posts

Drives: BMW f20 116i
Join Date: Dec 2017
Location: Netherlands

iTrader: (0)

Garage List
2012 BMW F20  [5.00]
Thatís solved! Great! Does the CarPlay unit works?
Appreciate 0
      09-23-2020, 09:38 AM   #14
328iking
Private First Class
15
Rep
193
Posts

Drives: 328i
Join Date: Apr 2019
Location: Ipswich, Suffolk

iTrader: (0)

Quote:
Originally Posted by Sidewinder1970 View Post
That’s solved! Great! Does the CarPlay unit works?
Yeah all works fine even before.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:39 AM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST