BMW 1-Series Forum (F20) 135i - 1Addicts.com > Second Generation 1 Series Forum > DIY Guides and Instructions > Coding Help - Head Unit
Post Reply
 
Thread Tools Search this Thread
      02-16-2019, 05:52 PM   #1
domgreenslade
Registered
4
Rep
2
Posts

Drives: BMW F20
Join Date: Jul 2018
Location: United Kingdom

iTrader: (0)

Coding Help - Head Unit

Hi Guys
Let me explain what i've just done. I've removed my old basic head unit that had basic bluetooth for calls and no nav, and replaced it with the basic gps headunit (6822077). Basically installed NBT emulator, gps antenna and got the esys cable ready to go. Installed the head unit today and works fine, I just need to code it in now, but I feel really overwhelmed when I'm looking at what i need to do. I've followed the tutorial, got my laptop connected to my car and get as far as activating FA, which works fine and connects fine, I just have no actual idea what it is I am looking to code. All I know is that the head unit works fine, I just have no connection between the head unit and the instrument cluster, so seemingly need to code that in.

Can someone tell me what it is that I actually need to code, or what VO codes I need to code. The more I look the more confused I get, as I believe I need to code S606, but might be S609, and even then I am not sure I am even looking at the right thing! Please and thank you to anyone that can help a desperate man out!
Appreciate 0
      03-20-2019, 07:13 AM   #2
88tuning.id
Private First Class
88tuning.id's Avatar
Indonesia
35
Rep
134
Posts

Drives: E39 520i Msport
Join Date: Mar 2019
Location: Indonesia

iTrader: (0)

Quote:
Originally Posted by domgreenslade View Post
Hi Guys
Let me explain what i've just done. I've removed my old basic head unit that had basic bluetooth for calls and no nav, and replaced it with the basic gps headunit (6822077). Basically installed NBT emulator, gps antenna and got the esys cable ready to go. Installed the head unit today and works fine, I just need to code it in now, but I feel really overwhelmed when I'm looking at what i need to do. I've followed the tutorial, got my laptop connected to my car and get as far as activating FA, which works fine and connects fine, I just have no actual idea what it is I am looking to code. All I know is that the head unit works fine, I just have no connection between the head unit and the instrument cluster, so seemingly need to code that in.

Can someone tell me what it is that I actually need to code, or what VO codes I need to code. The more I look the more confused I get, as I believe I need to code S606, but might be S609, and even then I am not sure I am even looking at the right thing! Please and thank you to anyone that can help a desperate man out!
Hi Dom, have you sort this problem out?

please pm me 7digits of your vin, imma check the option your car has in the beginning.

if not, i can assist you via team viewer.

T
__________________
Instagram: @tafikhulafaa & @88tuning.id
Appreciate 0
      05-26-2019, 05:32 AM   #3
ekumi
Registered
0
Rep
2
Posts

Drives: f20 116d 2011
Join Date: May 2019
Location: united kingdom

iTrader: (0)

Can anyone give me a hand with coding also please. I have retrofitted an NBT from an f30 into my f20. The NBT has bmw apps etc but the head unit still shows the donor vehicle information etc how do i get this to show my vehicles info, and if i do this will i lose things such as bmw apps and voice control?
Appreciate 0
      11-17-2020, 07:10 PM   #4
Ludvik
Registered
0
Rep
2
Posts

Drives: BMW 2012 F20 116ED
Join Date: Nov 2020
Location: Norway

iTrader: (0)

Im wondering about the same thing. Im kind of green with it comes to coding..

I just purchased and received my new unit. I have a BMW 116D 2012 without nav and bt streaming, only for calls.

The new head unit: 65128792157 - I also have the 6.5 glossy screen and the control unit from the same donor car (a 2017 f20).

I've also ordered the following:

gps antenna: https://www.ebay.co.uk/p/597111760?iid=172172919212
nbt emulator: https://www.aliexpress.com/item/3261304 ... HZaVO&mp=1

Hoping these are the right and compatible parts.. And is there anyone that knows a good guide on the e-sys part? If anyone would be interested in helping me with the code part, I'll pay happily Looking forward to the install!

Thanks!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:15 AM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST