BMW 1-Series Forum (F20) 135i - 1Addicts.com > Second Generation 1 Series Forum > 2012 BMW 1-Series Sporthatch (F20) Discussion > Alpine Retrofit Audio Upgrade kit for the F20
Post Reply
 
Thread Tools Search this Thread
      10-29-2012, 10:12 AM   #23
LatinBimmer
First Lieutenant
 
Drives: X1 2013 White, F20 116i Black
Join Date: May 2012
Location: Lima

Posts: 305
iTrader: (0)

Great... I'll ask for a quote today ..and I'll wait for your install instructions
LatinBimmer is offline   Peru
0
Reply With Quote
      11-05-2012, 08:10 AM   #24
threerosedale
New Member
 
Drives: F20 118d SE
Join Date: Oct 2012
Location: United Kingdom

Posts: 5
iTrader: (0)

Hi Prajayn. Can you confirm that you have the Professional Radio (663) installed in your F20? BMW are giving me a hard time saying that the Alpine upgrade isn't compatible with my 118d SE (which has 663 installed). It's odd given the installation instructions specifically describing which diplexer connector to attach to the fron speakers.

Has any one else tried to purchase an Alpine upgrade kit from BMW to be told that there car is not compatible ??
threerosedale is offline  
0
Reply With Quote
      11-05-2012, 10:16 AM   #25
ivers1
New Member
 
ivers1's Avatar
 
Drives: 2007 E91 325d M-Sport
Join Date: Oct 2009
Location: Akershus

Posts: 19
iTrader: (0)

Op: These guys deliver speakers with 3 hole mounting for BMW in good quality: http://www.bavariansoundwerks.com.
They dont have F20 in their system, but the speakers are probably the same size as in other BMW`s.
__________________
2013 F21 116d Msport
2007 E91 325d M sport
x 2008 520dAT, x 2006 320d M sport, x 2004 320 dA M sport, x 2002 Mini Cooper S
ivers1 is online now   Norway
0
Reply With Quote
      11-05-2012, 10:18 AM   #26
LatinBimmer
First Lieutenant
 
Drives: X1 2013 White, F20 116i Black
Join Date: May 2012
Location: Lima

Posts: 305
iTrader: (0)

Quote:
Originally Posted by threerosedale View Post
Hi Prajayn. Can you confirm that you have the Professional Radio (663) installed in your F20? BMW are giving me a hard time saying that the Alpine upgrade isn't compatible with my 118d SE (which has 663 installed). It's odd given the installation instructions specifically describing which diplexer connector to attach to the fron speakers.

Has any one else tried to purchase an Alpine upgrade kit from BMW to be told that there car is not compatible ??
Same here..My dealer told me the same... it's not compatible...I don't understand.
LatinBimmer is offline   Peru
0
Reply With Quote
      11-05-2012, 03:06 PM   #27
threerosedale
New Member
 
Drives: F20 118d SE
Join Date: Oct 2012
Location: United Kingdom

Posts: 5
iTrader: (0)

Alpine upgrade

Quote:
Originally Posted by iBeech View Post
yes please
Hi iBeech. As you're in Stoke ... is Knights your local dealer? Do you have a Professional Radio (663) ?? And have you asked them to quote for an Alpine upgrade ?
threerosedale is offline  
0
Reply With Quote
      11-05-2012, 03:13 PM   #28
iBeech
Captain
 
iBeech's Avatar
 
Drives: BMW 116i F20 Estoril Blue
Join Date: Sep 2009
Location: Stoke

Posts: 929
iTrader: (1)

Garage List
Send a message via MSN to iBeech Send a message via Skype™ to iBeech
Quote:
Originally Posted by threerosedale
Quote:
Originally Posted by iBeech View Post
yes please
Hi iBeech. As you're in Stoke ... is Knights your local dealer? Do you have a Professional Radio (663) ?? And have you asked them to quote for an Alpine upgrade ?
I have standard m sport- whatever that means?

Knights is my local dealer- i'll ring and ask tomorrow fora quote for u
__________________
iBeech is offline   England
0
Reply With Quote
      11-08-2012, 02:12 PM   #29
prajayn
New Member
 
Drives: 2012 F20 120d
Join Date: May 2012
Location: South Africa

Posts: 21
iTrader: (0)

Sorry for the delay guys, going to get this done tmw. Been a bit of a crazy week.

Also will take some pics of my radio - 663 is what I think I have but you guys can compare with yours.
prajayn is offline  
0
Reply With Quote
      11-08-2012, 04:08 PM   #30
LatinBimmer
First Lieutenant
 
Drives: X1 2013 White, F20 116i Black
Join Date: May 2012
Location: Lima

Posts: 305
iTrader: (0)

I was at my dealers today and again, their system says "not compatible with "SA663"...strange
LatinBimmer is offline   Peru
0
Reply With Quote
      12-05-2012, 12:20 PM   #31
wood23
Registered
 
Drives: 118d
Join Date: Nov 2012
Location: Santander

Posts: 1
iTrader: (0)

Impresions? Installation? Prajayn?
wood23 is offline  
0
Reply With Quote
      04-11-2013, 01:04 AM   #32
Afirst1
New Member
 
Drives: F20 116i
Join Date: Apr 2013
Location: Slovenia

Posts: 29
iTrader: (0)

Can we get pictures please? I'm also thinking about Alpine, but I have pro radio (with display, without navi)
Afirst1 is offline  
0
Reply With Quote
      04-14-2013, 06:29 AM   #33
prajayn
New Member
 
Drives: 2012 F20 120d
Join Date: May 2012
Location: South Africa

Posts: 21
iTrader: (0)

Sorry guys. I've been on the job for a while. I will be stripping the doors and the rear again to replace the back speakers.

Apologies for this.

I will try my best to get this done this week sometime - not having my own garage is a pain in the a**.

Last edited by prajayn; 04-14-2013 at 06:37 AM.
prajayn is offline  
0
Reply With Quote
      06-24-2013, 11:59 AM   #34
krugerjq
Private First Class
 
Drives: X3 2d 2013, F800GS 2009
Join Date: Feb 2006
Location: South Africa

Posts: 115
iTrader: (0)

Quote:
Originally Posted by prajayn View Post
Sorry guys. I've been on the job for a while. I will be stripping the doors and the rear again to replace the back speakers.

Apologies for this.

I will try my best to get this done this week sometime - not having my own garage is a pain in the a**.
Hi, did you manage to take some pictures yet?

What did you pay for the kit? I'm also from SA and consider upgrading my wife's 118 sound.
krugerjq is offline   South Africa
0
Reply With Quote
      12-13-2013, 11:40 AM   #35
dave-the-rave
Private First Class
 
dave-the-rave's Avatar
 
Drives: M135i
Join Date: Dec 2011
Location: Manchester

Posts: 163
iTrader: (3)

I was told i couldnt install this because of the DAB Radio. could i not just unplug this ?

S606A NAVIGATIONSSYSTEM BUSINESS Navigation system Business
S654A DAB TUNER DAB tuner
dave-the-rave is offline   United Kingdom
0
Reply With Quote
      12-15-2013, 05:23 PM   #36
frs3052
Private
 
Drives: 118D M Sport
Join Date: Dec 2008
Location: Cheshire

Posts: 57
iTrader: (0)

How much is the alpine upgrade on an f20 and does it work with the dab?
frs3052 is offline   United Kingdom
0
Reply With Quote
      12-16-2013, 02:12 PM   #37
dave-the-rave
Private First Class
 
dave-the-rave's Avatar
 
Drives: M135i
Join Date: Dec 2011
Location: Manchester

Posts: 163
iTrader: (3)

i was told it cant because of the dab, that's why i'm hopeful someone knows whether or not it can be removed!
dave-the-rave is offline   United Kingdom
0
Reply With Quote
      12-19-2013, 06:34 AM   #38
dave-the-rave
Private First Class
 
dave-the-rave's Avatar
 
Drives: M135i
Join Date: Dec 2011
Location: Manchester

Posts: 163
iTrader: (3)

It seems the old kit isn't being produced now, and there's a newer one, that may fit ?

65412293994
dave-the-rave is offline   United Kingdom
0
Reply With Quote
      12-27-2013, 10:53 AM   #39
paolo52
Registered
 
Drives: bmw 120d f20
Join Date: Dec 2013
Location: Italy

Posts: 1
iTrader: (0)

Info kit alpine f20

Quote:
Originally Posted by prajayn View Post
So what I found is that the front splits are heavily attenuated so most of the bass and midrange come from under the seats and the back speakers.

Back speakers are as per the photo - what came out of the front doors I think. I will double check later. From what I am hearing, they are bottoming out and killing the rest of the sound quality. I am going to look for replacements and also add in a simple passive crossover to kill the bass going there.

Just looking online I can see that its impossible to find something with a 3 hole mount, will have to make a spacer or something to get it in there.

But then thats it.

ps. this car was as easy to strip as my polo, and once I plugged everything back in, the only error I had was the time/date.

Saved myself a couple of grand doing this DIY. Just need to order the tweeter pods now, currently just plugged in a set of infinity reference tweeters I had laying about.

Sound quality is not the most amazing, but I think what I am not liking is coming from the standard rears, will decide once those are out.
can i have more photos for amplifier connection..?
Thanks
paolo52 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:55 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST